1 |
elmer |
1.11 |
### RPM external sigcpp 2.0.18
|
2 |
elmer |
1.6 |
%define majorv %(echo %realversion | cut -d. -f1,2)
|
3 |
|
|
Source: http://ftp.gnome.org/pub/GNOME/sources/libsigc++/%{majorv}/libsigc++-%{realversion}.tar.gz
|
4 |
elmer |
1.11 |
Patch0: sigcpp-2.0.18-gcc42
|
5 |
ratnik |
1.1 |
|
6 |
|
|
%prep
|
7 |
elmer |
1.6 |
%setup -q -n libsigc++-%{realversion}
|
8 |
elmer |
1.11 |
case %gccver in
|
9 |
|
|
4.3.*)
|
10 |
|
|
%patch0 -p2
|
11 |
|
|
;;
|
12 |
|
|
esac
|
13 |
elmer |
1.6 |
./configure --prefix=%{i}
|
14 |
ratnik |
1.1 |
|
15 |
|
|
%build
|
16 |
eulisse |
1.2 |
make %makeprocesses
|
17 |
eulisse |
1.3 |
%install
|
18 |
|
|
make install
|
19 |
|
|
cp %i/lib/sigc++-%{majorv}/include/sigc++config.h %i/include/sigc++-%{majorv}/
|
20 |
muzaffar |
1.8 |
# SCRAM ToolBox toolfile
|
21 |
|
|
mkdir -p %i/etc/scram.d
|
22 |
|
|
cat << \EOF_TOOLFILE >%i/etc/scram.d/%n
|
23 |
|
|
<doc type=BuildSystem::ToolDoc version=1.0>
|
24 |
|
|
<Tool name=sigcpp version=%v>
|
25 |
|
|
<lib name=sigc-2.0>
|
26 |
|
|
<Client>
|
27 |
|
|
<Environment name=SIGCPP_BASE default="%i"></Environment>
|
28 |
|
|
<Environment name=LIBDIR default="$SIGCPP_BASE/lib"></Environment>
|
29 |
|
|
<Environment name=INCLUDE default="$SIGCPP_BASE/include/sigc++-2.0"></Environment>
|
30 |
|
|
</Client>
|
31 |
|
|
</Tool>
|
32 |
|
|
EOF_TOOLFILE
|
33 |
|
|
|
34 |
|
|
%post
|
35 |
|
|
%{relocateConfig}etc/scram.d/%n
|