ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/simage.spec
Revision: 1.9
Committed: Tue May 1 10:57:27 2007 UTC (18 years ago) by elmer
Branch: MAIN
CVS Tags: pe20070522a-ports, pe20070519a-ports, pe20070512a-ports, pe20070508a-ports, pe20070507a-ports, pe20070501c-ports, pe20070501b-ports, pe20070501a-ports
Changes since 1.8: +0 -2 lines
Log Message:
Remove gcc-wrappers. scramv1-build.file still needs more work, will do in
a bit.

File Contents

# User Rev Content
1 eulisse 1.1 ### RPM external simage 1.6.1
2     Source: http://ftp.coin3d.org/coin/src/all/%{n}-%{v}.tar.gz
3 eulisse 1.3 %define tmpplatf %(echo %cmsplatf | cut -d_ -f2)
4    
5     Requires: libungif libjpg zlib libpng
6     %if "%tmpplatf" != "amd64"
7     Requires: libtiff
8     %endif
9    
10 eulisse 1.1 %prep
11     %setup -n %{n}-%{v}
12 eulisse 1.2
13 eulisse 1.1 %build
14 eulisse 1.3 CONFIGURE_ENV=
15     CONFIGURE_OPTS="--with-tiff=$LIBTIFF_ROOT"
16     %if "%tmpplatf" == "amd64"
17     CONFIGURE_ENV="LD=gcc"
18     CONFIGURE_OPTS="--without-tiff"
19     %endif
20    
21     ./configure $CONFIGURE_ENV --prefix=%i \
22     $CONFIGURE_OPTS \
23 eulisse 1.2 --with-ungif=$LIBUNGIF_ROOT \
24     --with-jpeg=$LIBJPG_ROOT \
25     --with-zlib=$ZLIB_ROOT \
26     --with-png=$LIBPNG_ROOT \
27 eulisse 1.3 --without-oggvorbis
28 eulisse 1.4 make
29 eulisse 1.6
30     %post
31     %{relocateConfig}bin/simage-config
32 eulisse 1.7 %{relocateConfig}lib/libsimage.la
33     %{relocateConfig}share/Coin/conf/simage-default.cfg