ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/sip.spec
Revision: 1.7
Committed: Tue Nov 10 18:39:08 2009 UTC (15 years, 5 months ago) by elmer
Branch: MAIN
CVS Tags: CMSSW_3_3_6_patch6, sm100215, CMSSW_3_3_6_patch5, apFor336p5v1, CMSSW_3_3_6_patch4, apFor336p5v0, for336patch4, CMSSW_3_3_3_TSG, sm100115-333tsg, CMSSW_3_3_6_patch3, apFor336p3v0, CMSSW_3_3_6_patch1, eskFor336ptch1, CMSSW_3_3_6, CMSSW_3_3_6_slc5-gcc434, apFor336v0-slc5-gcc434, apFor336v0, CMSSW_3_3_5_patch4, CMSSW_3_3_5_patch4_slc5-gcc434, apFor335p4v0-slc5-gcc434, apFor335p4-slc5-gcc434, apFor335p4v0, CMSSW_3_3_5_patch3, CMSSW_3_3_5_patch3_slc5-gcc434, apFor335p3v0-slc5-gcc434, apFor335p3v0, CMSSW_3_3_5_patch2_slc5-gcc434, CMSSW_3_3_5_patch2, CMSSW_3_3_3_onlpatch5_ONLINE, apFor335p2v0-slc5-gcc434, apFor335p2v0, CMSSW_3_3_5_patch1_slc5-gcc434, CMSSW_3_3_5_patch1, apFor335pat1v2-slc5-gcc434, apFor335pat1v2, apFor335pat1v1, apFor335pat1v1-slc5-gcc434, apFor335pat1v0-slc5-gcc434, apFor335pat1v0, lsFor335patch1, lsFOR335patch1v0, CMSSW_3_3_5_slc5-gcc434, CMSSW_3_3_5, CMSSW_3_3_3_onlpatch4_ONLINE, apFor335v0, apFor335v0-sl5igcc4, pe20091126a-for33X-slc4-gcc345, pe20091126a-for33X-slc5-gcc434, CMSSW_3_3_3_onlpatch2_ONLINE, CMSSW_3_3_3_onlpatch3_ONLINE, CMSSW_3_3_4_slc5-gcc434, CMSSW_3_3_4, apFor334v0-sl5igcc4, apFor334v0, CMSSW_3_3_3_DQM, apFor333dqmv0, CMSSW_3_3_3_patch1, CMSSW_3_3_3_slc5-gcc434, lmFor333pat1v0, CMSSW_3_3_3_ONLINE, fw20091114b, fw20091114a, ap20091114a, fw20091114, ap20091114, CMSSW_3_3_3, pe20091113c-for33X-slc5-gcc434, pe20091113b-for33X-slc5-gcc434, pe20091113a-for33X-slc5-gcc434, pe20091113a-for33X-slc4-gcc345, apFor333v1-sl5igcc4, apFor333v1-sl4igcc4, apFor333v1, pe20091110c-for33X-slc5-gcc434, pe20091110c-for33X-slc4-gcc432, pe20091110c-for33X-slc4-gcc345
Changes since 1.6: +1 -1 lines
Log Message:
Hardcode the python path back to "python2.4" for the relocation, as the use
of $PYTHON_VERSION doesn't work at that point. This revision is for 33X.

File Contents

# Content
1 ### RPM external sip 4.8.2
2 ## INITENV +PATH PYTHONPATH %i/lib/python$(echo $PYTHON_VERSION |cut -d. -f 1,2)/site-packages
3 Source: http://www.riverbankcomputing.co.uk/static/Downloads/sip4/sip-%realversion.tar.gz
4 Requires: python
5 %prep
6 %setup -n sip-%realversion
7
8 %build
9 python ./configure.py -v %i/share -b %i/bin -d %i/lib/python`echo $PYTHON_VERSION | cut -d. -f 1,2`/site-packages -e %i/include
10 make %makeprocesses
11
12 %install
13 make install
14
15 mkdir -p %i/etc/scram.d
16 cat << \EOF_TOOLFILE >%i/etc/scram.d/sip
17 <doc type=BuildSystem::ToolDoc version=1.0>
18 <Tool name=sip version=%v>
19 <info url="http://www.riverbankcomputing.co.uk/software/sip/intro"></info>
20 <Client>
21 <Environment name=SIP_BASE default="%i"></Environment>
22 </Client>
23 <Runtime name=PYTHONPATH value="$SIP_BASE/lib/python@PYTHONV@/site-packages" type=path>
24 <use name="python">
25 </Tool>
26 EOF_TOOLFILE
27
28 export PYTHONV=$(echo $PYTHON_VERSION | cut -f1,2 -d.)
29 perl -p -i -e 's|\@([^@]*)\@|$ENV{$1}|g' %i/etc/scram.d/*
30
31 %post
32 %{relocateConfig}etc/scram.d/sip
33 %{relocateConfig}lib/python2.4/site-packages/sipconfig.py