ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/soqt.spec
Revision: 1.3
Committed: Wed Mar 15 21:37:14 2006 UTC (19 years, 1 month ago) by eulisse
Branch: MAIN
CVS Tags: CRABSERVER_TEST_BUILD_V4, CRABSERVER_TEST_BUILD_V3, CRABSERVER_TEST_BUILD_V2, CRABSERVER_TEST_BUILD_V1, forCRABSERVER104test, forCRABSERVER103, PRODAGENT_0_10_12_V10, PRODAGENT_0_10_12_V9, PRODAGENT_0_10_12_V8, PRODAGENT_0_10_12_V7, PRODAGENT_0_10_12_V6, PRODAGENT_0_10_12_V5, PRODAGENT_0_10_12_V4, forCS102pre4, PRODAGENT_0_10_12_V3, PRODAGENT_0_10_12_V2, PRODAGENT_0_10_12, PRODAGENT_0_10_3, PRODAGENT_0_10_3_20080521, PRODAGENT_0_8_3_SL4, forPA070pre3-slc3, forPA070pre3-slc4, forPA070pre3-slc, forPA061, forPA060pre7-slc4, forPA060pre3, forDBS106, forPA050pre3, WEBTOOLS_CONFIG_1_pre2, WEBTOOLS_CONFIG_1_pre1, forPA030, forPA020, PR_0_5_4, PR_0_5_0, PR_0_4_21, PRODREQUEST_0_4_0, PR0_3_13, PR0_3_12, PR0-3-11, forPR034, forPR033, forPIL116, forPR032, forPR030, forPR020, forPA011, forPR010, forPA010, af20060928, for100pre1, for091, for082, for090, CMSSW_0_8_1, for090_RC1, CMSSW_0_9_0_pre3, nr_baran081_t1, for080_testfixes1, for090p2, forCMSSW090p2, for080_testfixes, for090p2_RC5, for090p2_RC4, for090p2_RC3, for090p2_RC2, for090p2_RC1, ProdAgent_pa17, for081, for080_amd64, for080, for080p4, for080pre3, phedex_2_3_series, forLCG_44, forCMSSW_0_8_0_pre2, V00-01-02, V00-01-2, V00-01-01, V00-01-00, V00-00-11, V00-00-10, V00-00-09, V00-00-08, V00-00-07, V00-00-06, V00-00-05, V00-00-04, V00-00-03, V00-00-02, V00-00-01, V00-00-00, test2, test1, NataliaStart
Changes since 1.2: +1 -1 lines
Log Message:
Now uses patch to fix continuos rendering.

File Contents

# User Rev Content
1 eulisse 1.1 ### RPM external soqt 1.3.0
2     # 1.3.0-tgs, 1.3.0-coin (default: coin)
3     # FIXME: make type part of installation location!
4     %define soqttype %(echo %v | sed 's/[-0-9.]*//')
5     %define soqtversion %(echo %v | sed 's/-.*//')
6     %if "%soqttype" == ""
7     %define type coin
8     %else
9     %define type %{soqttype}
10     %endif
11     # define tgspath /some/path
12     # define qtpath /some/path
13    
14     Requires: qt
15     %if "%type" == "tgs"
16     Requires: tgsinventorfix
17     %else
18     Requires: coin
19     %endif
20    
21     Source: ftp://ftp.coin3d.org/pub/coin/src/SoQt-%{soqtversion}.tar.gz
22     # FIXME: forget about the patch for the time being.
23     # I need to ask lassi where to find it.
24 eulisse 1.3 Patch: soqt
25 eulisse 1.1
26     %prep
27     %setup -n SoQt-%{soqtversion}
28     #%patch0
29    
30     %build
31     case $(uname) in
32     Darwin ) threads= cfgflags="-without-framework --without-x" ;;
33     * ) threads=-pthread cfgflags= ;;
34     esac
35    
36     # Allow Qt location to be overridden from RPM command line
37     %if "%{?qtpath:set}" == "set"
38     QT_ROOT="%qtpath"
39     export QT_ROOT
40     %endif
41    
42     case "%type" in
43     tgs )
44     [ X"%tgspath" = X ] && { echo "%%tgspath not defined" 1>&2; exit 1; }
45    
46     # FIXME: OpenGL home? (-L, --with-opengl=...)
47     # FIXME: KCC/Linux needs -D__ELF__ -lz -lm
48     # FIXME: KCC/Solaris needs -lm
49     # FIXME: KCC/IRIX needs -lm; CC=$(CXX) CFLAGS=$(CFLAGS) (can't link C++ with KCC --c)
50     # FIXME: Merge CFLAGS/CXXFLAGS to CC/CXX because of abi-changing meaning; zero out the flags
51     # FIXME: Need -DENABLE_NLS -DEHAVE_GETTEXT for GCC 3.x on linuxen?
52     # FIXME: Need --enable-exceptions?
53     # FIXME: Need MAKE=...?
54     # FIXME: Need -pthread / --enable-threads?
55     ./configure --prefix=%i \
56     --with-inventor=%tgspath --without-coin \
57     --with-qt=$QT_ROOT --disable-dependency-tracking \
58     --disable-libtool-lock $cfgflags \
59     LDFLAGS="-L%tgspath" CXX="c++ $threads" \
60     LIBS="-L$TGSINVENTORFIX_ROOT/lib -lTGSInventorFix" ;;
61    
62     coin )
63     ./configure --prefix=%i --with-coin=$COIN_ROOT \
64     --with-qt=$QT_ROOT --disable-dependency-tracking \
65     --disable-libtool-lock $cfgflags \
66     CXX="c++ $threads" ;;
67    
68     * )
69     echo "unknown soqt build type %type" 1>&2
70     exit 1 ;;
71     esac
72 eulisse 1.2 make %makeprocesses