1 |
elmer |
1.21 |
### RPM external sqlite 3.6.10
|
2 |
|
|
Source: http://www.sqlite.org/sqlite-%{realversion}.tar.gz
|
3 |
eulisse |
1.14 |
Patch1: sqlite_%{realversion}_readline_for_32bit_on_64bit_build
|
4 |
elmer |
1.11 |
|
5 |
|
|
%prep
|
6 |
|
|
%setup -n %n-%{realversion}
|
7 |
elmer |
1.12 |
# The following hack and patch are there because the libreadline.so soft
|
8 |
|
|
# link is missing from the 32-bit compatibility area on the 64-bit build
|
9 |
|
|
# machines and apparently they don't have a -devel build with it. It
|
10 |
|
|
# definitely should be reviewed at some point.
|
11 |
eulisse |
1.14 |
%patch1 -p1
|
12 |
elmer |
1.12 |
mkdir .libs
|
13 |
elmer |
1.22 |
# Workaround for the lack of a 32bit readline-devel rpm for SL4
|
14 |
|
|
# Given that the 64bit readline-devel is there, the headers are there,
|
15 |
|
|
# the only thing missing is the libreadline.so symlink. This is not
|
16 |
|
|
# a problem for SL5.
|
17 |
|
|
case %cmsos in
|
18 |
|
|
slc4*ia32 )
|
19 |
|
|
ln -s /usr/lib/libreadline.so.4.3 .libs/libreadline.so
|
20 |
|
|
;;
|
21 |
|
|
esac
|
22 |
elmer |
1.11 |
|
23 |
eulisse |
1.1 |
%build
|
24 |
|
|
./configure --prefix=%i --disable-tcl
|
25 |
eulisse |
1.2 |
make %makeprocesses
|
26 |
muzaffar |
1.16 |
|
27 |
|
|
%install
|
28 |
|
|
make install
|
29 |
|
|
# SCRAM ToolBox toolfile
|
30 |
|
|
mkdir -p %i/etc/scram.d
|
31 |
muzaffar |
1.23 |
cat << \EOF_TOOLFILE >%i/etc/scram.d/%n.xml
|
32 |
|
|
<tool name="%n" version="%v">
|
33 |
|
|
<lib name="sqlite3"/>
|
34 |
|
|
<client>
|
35 |
|
|
<environment name="SQLITE_BASE" default="%i"/>
|
36 |
|
|
<environment name="LIBDIR" default="$SQLITE_BASE/lib"/>
|
37 |
|
|
<environment name="BINDIR" default="$SQLITE_BASE/bin"/>
|
38 |
|
|
<environment name="INCLUDE" default="$SQLITE_BASE/include"/>
|
39 |
|
|
</client>
|
40 |
|
|
<runtime name="PATH" value="$BINDIR" type="path"/>
|
41 |
|
|
</tool>
|
42 |
muzaffar |
1.16 |
EOF_TOOLFILE
|
43 |
|
|
|
44 |
|
|
%post
|
45 |
muzaffar |
1.23 |
%{relocateConfig}etc/scram.d/%n.xml
|