ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/srmcp.spec
Revision: 1.1
Committed: Thu May 4 17:15:15 2006 UTC (18 years, 11 months ago) by eulisse
Branch: MAIN
Log Message:
- install.sh now support https (when using wget)
- srmcp first added to repository.

File Contents

# User Rev Content
1 eulisse 1.1 ### RPM external srmcp 1.23
2     ## INITENV +PATH PATH %i/srmclient/bin
3     ## INITENV SET SRM_PATH %i/srmclient
4     ## INITENV SET SRM_CONFIG %i/etc/config.xml
5    
6     %define downloadv %(echo %v | tr . _)
7     Source: https://srm.fnal.gov/twiki/pub/SrmProject/SrmcpClient/%{n}_v%{downloadv}_NULL.tar
8    
9     %prep
10     %setup -n srmclient
11     %build
12    
13     %install
14     unset SRM_PATH SRM_CONFIG || true
15     (cd .. && tar -cf - srmclient) | (cd %i && tar -xf -)
16     if [ ! -f $HOME/.srmconfig/config.xml ]; then
17     mkdir -p %i/etc $HOME/.srmconfig
18     SRM_PATH=%i/srmclient %i/srmclient/sbin/srm \
19     -copy file:///dev/null file:///dev/null > /dev/null 2>&1 || true
20     [ -f $HOME/.srmconfig/config.xml ]
21     fi
22    
23     mkdir -p %i/etc
24     cp -p $HOME/.srmconfig/config.xml %i/etc/config.xml
25     perl -p -i -e "s|$HOME|%i|" %i/etc/config.xml
26    
27     %post
28     %{relocateConfig}.srmconfig/config.xml