ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/srmcp.spec
Revision: 1.3
Committed: Thu Sep 7 22:01:16 2006 UTC (18 years, 7 months ago) by mballint
Branch: MAIN
Changes since 1.2: +2 -1 lines
Log Message:
- Add missing dependency on java-sdk
- Fix SRM URL format

File Contents

# User Rev Content
1 eulisse 1.1 ### RPM external srmcp 1.23
2     ## INITENV +PATH PATH %i/srmclient/bin
3     ## INITENV SET SRM_PATH %i/srmclient
4     ## INITENV SET SRM_CONFIG %i/etc/config.xml
5    
6     %define downloadv %(echo %v | tr . _)
7     Source: https://srm.fnal.gov/twiki/pub/SrmProject/SrmcpClient/%{n}_v%{downloadv}_NULL.tar
8 mballint 1.3 Requires: java-jdk
9 eulisse 1.1
10     %prep
11     %setup -n srmclient
12     %build
13    
14     %install
15     unset SRM_PATH SRM_CONFIG || true
16     (cd .. && tar -cf - srmclient) | (cd %i && tar -xf -)
17     if [ ! -f $HOME/.srmconfig/config.xml ]; then
18     mkdir -p %i/etc $HOME/.srmconfig
19     SRM_PATH=%i/srmclient %i/srmclient/sbin/srm \
20 mballint 1.3 -copy file:////dev/null file:////dev/null > /dev/null 2>&1 || true
21 eulisse 1.1 [ -f $HOME/.srmconfig/config.xml ]
22     fi
23    
24     mkdir -p %i/etc
25     cp -p $HOME/.srmconfig/config.xml %i/etc/config.xml
26     perl -p -i -e "s|$HOME|%i|" %i/etc/config.xml
27    
28     %post
29 lat 1.2 %{relocateConfig}etc/config.xml