ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/srmcp.spec
Revision: 1.4
Committed: Tue Sep 26 16:15:11 2006 UTC (18 years, 7 months ago) by rehn
Branch: MAIN
CVS Tags: pe060927
Changes since 1.3: +0 -1 lines
Log Message:
Don't depend on JDK.

File Contents

# User Rev Content
1 eulisse 1.1 ### RPM external srmcp 1.23
2     ## INITENV +PATH PATH %i/srmclient/bin
3     ## INITENV SET SRM_PATH %i/srmclient
4     ## INITENV SET SRM_CONFIG %i/etc/config.xml
5    
6     %define downloadv %(echo %v | tr . _)
7     Source: https://srm.fnal.gov/twiki/pub/SrmProject/SrmcpClient/%{n}_v%{downloadv}_NULL.tar
8    
9     %prep
10     %setup -n srmclient
11     %build
12    
13     %install
14     unset SRM_PATH SRM_CONFIG || true
15     (cd .. && tar -cf - srmclient) | (cd %i && tar -xf -)
16     if [ ! -f $HOME/.srmconfig/config.xml ]; then
17     mkdir -p %i/etc $HOME/.srmconfig
18     SRM_PATH=%i/srmclient %i/srmclient/sbin/srm \
19 mballint 1.3 -copy file:////dev/null file:////dev/null > /dev/null 2>&1 || true
20 eulisse 1.1 [ -f $HOME/.srmconfig/config.xml ]
21     fi
22    
23     mkdir -p %i/etc
24     cp -p $HOME/.srmconfig/config.xml %i/etc/config.xml
25     perl -p -i -e "s|$HOME|%i|" %i/etc/config.xml
26    
27     %post
28 lat 1.2 %{relocateConfig}etc/config.xml