1 |
rehn |
1.8 |
### RPM external srmcp 1.25
|
2 |
eulisse |
1.1 |
## INITENV +PATH PATH %i/srmclient/bin
|
3 |
|
|
## INITENV SET SRM_PATH %i/srmclient
|
4 |
|
|
## INITENV SET SRM_CONFIG %i/etc/config.xml
|
5 |
|
|
|
6 |
|
|
%define downloadv %(echo %v | tr . _)
|
7 |
|
|
Source: https://srm.fnal.gov/twiki/pub/SrmProject/SrmcpClient/%{n}_v%{downloadv}_NULL.tar
|
8 |
|
|
|
9 |
|
|
%prep
|
10 |
|
|
%setup -n srmclient
|
11 |
|
|
%build
|
12 |
|
|
|
13 |
|
|
%install
|
14 |
|
|
unset SRM_PATH SRM_CONFIG || true
|
15 |
|
|
(cd .. && tar -cf - srmclient) | (cd %i && tar -xf -)
|
16 |
rehn |
1.7 |
mkdir -p %i/etc
|
17 |
|
|
SRM_PATH=%i/srmclient SRM_CONFIG=%i/etc/config.xml \
|
18 |
|
|
%i/srmclient/sbin/srm \
|
19 |
|
|
-x509_user_trusted_certificates /etc/grid-security/certificates \
|
20 |
mballint |
1.3 |
-copy file:////dev/null file:////dev/null > /dev/null 2>&1 || true
|
21 |
eulisse |
1.1 |
|
22 |
|
|
perl -p -i -e "s|$HOME|%i|" %i/etc/config.xml
|
23 |
|
|
|
24 |
|
|
%post
|
25 |
lat |
1.2 |
%{relocateConfig}etc/config.xml
|