1 |
steen |
1.1 |
### RPM external tdb 1.0.6
|
2 |
ratnik |
1.3 |
Requires: gcc-wrapper
|
3 |
steen |
1.1 |
|
4 |
|
|
Summary: Trivial Database
|
5 |
|
|
Group: System Environment/Libraries
|
6 |
|
|
URL: http://sourceforge.net/projects/tdb/
|
7 |
|
|
|
8 |
|
|
Packager:Conrad Steenberg <conrad@hep.caltech.edu>
|
9 |
|
|
Vendor: Conrad Steenberg <conrad@hep.caltech.edu>
|
10 |
|
|
|
11 |
|
|
Source: http://surfnet.dl.sourceforge.net/sourceforge/tdb/tdb-%{v}.tar.gz
|
12 |
|
|
Patch0: tdb-1.0.6-gcc33
|
13 |
|
|
Patch1: tdb-1.0.6-libjio
|
14 |
|
|
Requires: libjio gcc
|
15 |
|
|
|
16 |
|
|
|
17 |
|
|
%description
|
18 |
|
|
TDB is a Trivial Database. In concept, it is very much like GDBM,
|
19 |
|
|
and BSD's DB except that it allows multiple simultaneous writers
|
20 |
|
|
and uses locking internally to keep writers from trampling on
|
21 |
|
|
each other. TDB is also extremely small.
|
22 |
|
|
|
23 |
|
|
%prep
|
24 |
|
|
%setup -n tdb-%{v}
|
25 |
|
|
%patch0 -b .gcc3
|
26 |
|
|
%patch1 -p1 -b .jio
|
27 |
|
|
|
28 |
|
|
%build
|
29 |
ratnik |
1.3 |
## IMPORT gcc-wrapper
|
30 |
steen |
1.1 |
echo LIBJIO_ROOT=$LIBJIO_ROOT
|
31 |
steen |
1.2 |
export CFLAGS="-I%{i}/include -I$LIBJIO_ROOT/include -D_FILE_OFFSET_BITS=64"\
|
32 |
|
|
LDFLAGS="-L%{i}/lib -L$LIBJIO_ROOT/lib -ljio -lpthread"
|
33 |
steen |
1.1 |
./configure --prefix %{i}
|
34 |
|
|
make TDBTEST="" LDFLAGS="-L%{i}/lib -L$LIBJIO_ROOT/lib -ljio -lpthread"
|
35 |
|
|
|
36 |
|
|
%install
|
37 |
|
|
rm -rf %{buildroot}
|
38 |
|
|
make install TDBTEST=""
|
39 |
|
|
|
40 |
|
|
### Clean up buildroot
|
41 |
|
|
#%{__rm} -f %{buildroot}%{_libdir}/*.la
|
42 |
|
|
|
43 |
|
|
docdir=%{i}/doc/%{n}-%{v}
|
44 |
|
|
mkdir -p $docdir
|
45 |
|
|
|
46 |
|
|
cp AUTHORS ChangeLog COPYING NEWS README TODO $docdir
|
47 |
|
|
|
48 |
|
|
|
49 |
|
|
%files
|
50 |
|
|
%defattr(-, root, root, 0755)
|
51 |
|
|
%{i}/lib/*.so.*
|
52 |
|
|
%{i}/bin
|
53 |
|
|
%{i}/etc
|
54 |
|
|
%{i}/doc
|
55 |
|
|
%{i}/lib/*.a
|
56 |
|
|
%{i}/include
|
57 |
|
|
#%{i}/man
|