1 |
muzaffar |
1.9 |
### RPM external valgrind 3.2.3-cms1
|
2 |
elmer |
1.10 |
## BUILDIF case $(uname):$(uname -m) in Linux:i*86 ) true ;; Linux:x86_64 ) true ;; Linux:ppc64 ) true ;; * ) false ;; esac
|
3 |
sashby |
1.7 |
%define realversion %(echo %v | cut -d- -f1)
|
4 |
|
|
Source: http://www.valgrind.org/downloads/%{n}-%{realversion}.tar.bz2
|
5 |
muzaffar |
1.9 |
Patch1: valgrind-vg323-p2-global
|
6 |
|
|
Patch2: valgrind-vg323-p2-dump
|
7 |
sashby |
1.7 |
|
8 |
|
|
%prep
|
9 |
|
|
%setup -n %n-%realversion
|
10 |
muzaffar |
1.9 |
%patch1 -p0
|
11 |
|
|
%patch2 -p0
|
12 |
sashby |
1.7 |
# CMS patch for segment sizes:
|
13 |
|
|
perl -p -i -e 's!VG_N_SEGMENTS 5000!VG_N_SEGMENTS 20000!; s!VG_N_SEGNAMES 1000!VG_N_SEGNAMES 4000!; s!VG_MAX_SEGNAMELEN 1000!VG_MAX_SEGNAMELEN 4000!' coregrind/m_aspacemgr/aspacemgr.c;
|
14 |
|
|
|
15 |
|
|
pwd
|
16 |
|
|
|
17 |
eulisse |
1.2 |
%build
|
18 |
|
|
./configure --prefix=%i
|
19 |
|
|
make %makeprocesses
|
20 |
eulisse |
1.4 |
%install
|
21 |
|
|
make install
|
22 |
|
|
perl -p -i -e 's|^#!.*perl(.*)|#!/usr/bin/env perl$1|' $(grep -r -e "^#!.*perl.*" %i | cut -d: -f 1)
|
23 |
elmer |
1.8 |
# I don't see how to make perl options work nicely with env, so drop the -w
|
24 |
|
|
# in these two scripts
|
25 |
|
|
perl -p -i -e 's|perl -w|perl|' %i/bin/callgrind_annotate
|
26 |
|
|
perl -p -i -e 's|perl -w|perl|' %i/bin/callgrind_control
|