ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/webtools.spec
Revision: 1.7
Committed: Fri Mar 30 12:41:48 2007 UTC (18 years, 1 month ago) by eulisse
Branch: MAIN
Changes since 1.6: +2 -1 lines
Log Message:
Revision bump.

File Contents

# User Rev Content
1 eulisse 1.6 ### RPM cms webtools ALPHA-cp3
2 eulisse 1.1 %define moduleName WEBTOOLS
3     %define exportName WEBTOOLS
4 eulisse 1.7 %define cvstag V00-09-00
5 eulisse 1.1 %define cvsserver cvs://:pserver:anonymous@cmscvs.cern.ch:2401/cvs_server/repositories/CMSSW?passwd=AA_:yZZ3e
6     Source: %cvsserver&strategy=checkout&module=%{moduleName}&nocache=true&export=%{exportName}&tag=-r%{cvstag}&output=/%{moduleName}.tar.gz
7    
8     %prep
9     %setup -n %{moduleName}
10     %build
11     %install
12     mkdir -p %i/etc
13     cp -r * %i
14     cat << \EOF_CHERRYPY_CONF > %i/etc/cherrypy.conf
15     # Serve a complete directory
16     [/Common]
17 eulisse 1.6 tools.staticdir.on = True
18     tools.staticdir.dir = %i/Common
19 eulisse 1.1 [/Templates]
20 eulisse 1.6 tools.staticdir.on = True
21     tools.staticdir.dir = %i/Templates
22 eulisse 1.5 # Serve a complete directory
23     [/WEBTOOLS/Common]
24 eulisse 1.6 tools.staticdir.on = True
25     tools.staticdir.dir = %i/Common
26 eulisse 1.5 [/WEBTOOLS/Templates]
27 eulisse 1.6 tools.staticdir.on = True
28     tools.staticdir.dir = %i/Templates
29 eulisse 1.1 EOF_CHERRYPY_CONF
30 eulisse 1.2 cat << \EOF_APACHE2_HEADER > %i/etc/apache2-header.conf
31     RewriteEngine On
32     RewriteBase /cms/services
33     EOF_APACHE2_HEADER
34    
35     cat << \EOF_APACHE2_CONF > %i/etc/apache2.conf
36     <Directory %i/Common>
37     Allow from all
38     </Directory>
39     <Directory %i/Templates>
40     Allow from all
41     </Directory>
42     EOF_APACHE2_CONF
43    
44     cat << \EOF_APACHE2_FOOTER > %i/etc/apache2-footer.conf
45     RewriteRule ^/cms/services/webtools/Common(.*)$ %i/Common$1
46     RewriteRule ^/cms/services/webtools/Templates(.*)$ %i/Templates$1
47     EOF_APACHE2_FOOTER
48    
49 eulisse 1.1 %post
50     %{relocateConfig}etc/cherrypy.conf
51 eulisse 1.2 %{relocateConfig}etc/apache2.conf
52     %{relocateConfig}etc/apache2-header.conf
53     %{relocateConfig}etc/apache2-footer.conf
54    
55 eulisse 1.7