ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/webtools.spec
Revision: 1.8
Committed: Fri Mar 30 12:56:53 2007 UTC (18 years, 1 month ago) by eulisse
Branch: MAIN
Changes since 1.7: +3 -0 lines
Log Message:
updated with fake provides for perl stuff used by derek in the
SecurityModule.

File Contents

# User Rev Content
1 eulisse 1.6 ### RPM cms webtools ALPHA-cp3
2 eulisse 1.1 %define moduleName WEBTOOLS
3     %define exportName WEBTOOLS
4 eulisse 1.7 %define cvstag V00-09-00
5 eulisse 1.1 %define cvsserver cvs://:pserver:anonymous@cmscvs.cern.ch:2401/cvs_server/repositories/CMSSW?passwd=AA_:yZZ3e
6     Source: %cvsserver&strategy=checkout&module=%{moduleName}&nocache=true&export=%{exportName}&tag=-r%{cvstag}&output=/%{moduleName}.tar.gz
7 eulisse 1.8 Provides: perl(CGI)
8     Provides: perl(Crypt::CBC)
9     Provides: perl(SecurityModule)
10 eulisse 1.1
11     %prep
12     %setup -n %{moduleName}
13     %build
14     %install
15     mkdir -p %i/etc
16     cp -r * %i
17     cat << \EOF_CHERRYPY_CONF > %i/etc/cherrypy.conf
18     # Serve a complete directory
19     [/Common]
20 eulisse 1.6 tools.staticdir.on = True
21     tools.staticdir.dir = %i/Common
22 eulisse 1.1 [/Templates]
23 eulisse 1.6 tools.staticdir.on = True
24     tools.staticdir.dir = %i/Templates
25 eulisse 1.5 # Serve a complete directory
26     [/WEBTOOLS/Common]
27 eulisse 1.6 tools.staticdir.on = True
28     tools.staticdir.dir = %i/Common
29 eulisse 1.5 [/WEBTOOLS/Templates]
30 eulisse 1.6 tools.staticdir.on = True
31     tools.staticdir.dir = %i/Templates
32 eulisse 1.1 EOF_CHERRYPY_CONF
33 eulisse 1.2 cat << \EOF_APACHE2_HEADER > %i/etc/apache2-header.conf
34     RewriteEngine On
35     RewriteBase /cms/services
36     EOF_APACHE2_HEADER
37    
38     cat << \EOF_APACHE2_CONF > %i/etc/apache2.conf
39     <Directory %i/Common>
40     Allow from all
41     </Directory>
42     <Directory %i/Templates>
43     Allow from all
44     </Directory>
45     EOF_APACHE2_CONF
46    
47     cat << \EOF_APACHE2_FOOTER > %i/etc/apache2-footer.conf
48     RewriteRule ^/cms/services/webtools/Common(.*)$ %i/Common$1
49     RewriteRule ^/cms/services/webtools/Templates(.*)$ %i/Templates$1
50     EOF_APACHE2_FOOTER
51    
52 eulisse 1.1 %post
53     %{relocateConfig}etc/cherrypy.conf
54 eulisse 1.2 %{relocateConfig}etc/apache2.conf
55     %{relocateConfig}etc/apache2-header.conf
56     %{relocateConfig}etc/apache2-footer.conf
57    
58 eulisse 1.7