ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/webtools.spec
Revision: 1.5
Committed: Fri Jan 12 15:46:47 2007 UTC (18 years, 3 months ago) by eulisse
Branch: MAIN
CVS Tags: PR_0_5_0, PR_0_4_21, PRODREQUEST_0_4_0, PR0_3_13, PR0_3_12, PR0-3-11, forPR034, forPR033, forPIL116, forPR032, forPR030, forPR020
Changes since 1.4: +8 -2 lines
Log Message:
Uses both /WEBTOOLS/Common and /Common to work around some unidentified bug.

File Contents

# Content
1 ### RPM cms webtools ALPHA
2 %define moduleName WEBTOOLS
3 %define exportName WEBTOOLS
4 %define cvstag DMWT_0_0_1
5 %define cvsserver cvs://:pserver:anonymous@cmscvs.cern.ch:2401/cvs_server/repositories/CMSSW?passwd=AA_:yZZ3e
6 Source: %cvsserver&strategy=checkout&module=%{moduleName}&nocache=true&export=%{exportName}&tag=-r%{cvstag}&output=/%{moduleName}.tar.gz
7
8 %prep
9 %setup -n %{moduleName}
10 %build
11 %install
12 mkdir -p %i/etc
13 cp -r * %i
14 cat << \EOF_CHERRYPY_CONF > %i/etc/cherrypy.conf
15 # Serve a complete directory
16 [/Common]
17 static_filter.on = True
18 static_filter.dir = %i/Common
19 [/Templates]
20 static_filter.on = True
21 static_filter.dir = %i/Templates
22 # Serve a complete directory
23 [/WEBTOOLS/Common]
24 static_filter.on = True
25 static_filter.dir = %i/Common
26 [/WEBTOOLS/Templates]
27 static_filter.on = True
28 static_filter.dir = %i/Templates
29 EOF_CHERRYPY_CONF
30 cat << \EOF_APACHE2_HEADER > %i/etc/apache2-header.conf
31 RewriteEngine On
32 RewriteBase /cms/services
33 EOF_APACHE2_HEADER
34
35 cat << \EOF_APACHE2_CONF > %i/etc/apache2.conf
36 <Directory %i/Common>
37 Allow from all
38 </Directory>
39 <Directory %i/Templates>
40 Allow from all
41 </Directory>
42 EOF_APACHE2_CONF
43
44 cat << \EOF_APACHE2_FOOTER > %i/etc/apache2-footer.conf
45 RewriteRule ^/cms/services/webtools/Common(.*)$ %i/Common$1
46 RewriteRule ^/cms/services/webtools/Templates(.*)$ %i/Templates$1
47 EOF_APACHE2_FOOTER
48
49 %post
50 %{relocateConfig}etc/cherrypy.conf
51 %{relocateConfig}etc/apache2.conf
52 %{relocateConfig}etc/apache2-header.conf
53 %{relocateConfig}etc/apache2-footer.conf
54