1 |
eulisse |
1.1 |
### RPM cms xcmsi-compatibility 1.0
|
2 |
|
|
# This spec is used to link the old scramdb to the new one.
|
3 |
eulisse |
1.2 |
Source: none
|
4 |
eulisse |
1.1 |
Requires: SCRAM SCRAMV1 cms-env
|
5 |
|
|
|
6 |
|
|
%prep
|
7 |
|
|
%build
|
8 |
|
|
%install
|
9 |
eulisse |
1.5 |
|
10 |
eulisse |
1.1 |
%post
|
11 |
eulisse |
1.5 |
echo "Linking old XCMSI scram database to the new one..."
|
12 |
|
|
if [ ! -f $RPM_INSTALL_PREFIX/Releases/SCRAM/scramdb/project.lookup ]
|
13 |
|
|
then
|
14 |
|
|
echo "XCMSI installation not found. Quitting without doing anything."
|
15 |
|
|
else
|
16 |
|
|
source $RPM_INSTALL_PREFIX/cmsset_default.sh
|
17 |
|
|
scramv1 db -link $RPM_INSTALL_PREFIX/Releases/SCRAM/scramdb/project.lookup
|
18 |
|
|
fi
|
19 |
|
|
|
20 |
eulisse |
1.6 |
%preun
|
21 |
|
|
echo "Unlinking old XCMSI scram database from the new one..."
|
22 |
|
|
if [ ! -f $RPM_INSTALL_PREFIX/Releases/SCRAM/scramdb/project.lookup ]
|
23 |
|
|
then
|
24 |
|
|
echo "XCMSI installation not found. Quitting without doing anything."
|
25 |
|
|
exit 0
|
26 |
|
|
else
|
27 |
|
|
source $RPM_INSTALL_PREFIX/cmsset_default.sh
|
28 |
|
|
scramv1 db -link $RPM_INSTALL_PREFIX/Releases/SCRAM/scramdb/project.lookup
|
29 |
|
|
fi
|