ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/xcmsi-compatibility.spec
Revision: 1.7
Committed: Tue Jul 18 16:52:30 2006 UTC (18 years, 9 months ago) by eulisse
Branch: MAIN
CVS Tags: nr_baran081_t1, for081, for080_amd64
Changes since 1.6: +3 -1 lines
Log Message:
-Properly unlink on exit
- links the scramv0 databases as well.

File Contents

# User Rev Content
1 eulisse 1.1 ### RPM cms xcmsi-compatibility 1.0
2     # This spec is used to link the old scramdb to the new one.
3 eulisse 1.2 Source: none
4 eulisse 1.1 Requires: SCRAM SCRAMV1 cms-env
5    
6     %prep
7     %build
8     %install
9 eulisse 1.5
10 eulisse 1.1 %post
11 eulisse 1.5 echo "Linking old XCMSI scram database to the new one..."
12     if [ ! -f $RPM_INSTALL_PREFIX/Releases/SCRAM/scramdb/project.lookup ]
13     then
14     echo "XCMSI installation not found. Quitting without doing anything."
15     else
16     source $RPM_INSTALL_PREFIX/cmsset_default.sh
17     scramv1 db -link $RPM_INSTALL_PREFIX/Releases/SCRAM/scramdb/project.lookup
18 eulisse 1.7 scramv1 db link $RPM_INSTALL_PREFIX/Releases/SCRAM/scramdb/project.lookup
19 eulisse 1.5 fi
20    
21 eulisse 1.6 %preun
22     echo "Unlinking old XCMSI scram database from the new one..."
23     if [ ! -f $RPM_INSTALL_PREFIX/Releases/SCRAM/scramdb/project.lookup ]
24     then
25     echo "XCMSI installation not found. Quitting without doing anything."
26     exit 0
27     else
28     source $RPM_INSTALL_PREFIX/cmsset_default.sh
29 eulisse 1.7 scramv1 db -unlink $RPM_INSTALL_PREFIX/Releases/SCRAM/scramdb/project.lookup
30     scramv0 db unlink $RPM_INSTALL_PREFIX/Releases/SCRAM/scramdb/project.lookup
31 eulisse 1.6 fi