ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/xcmsi-compatibility.spec
Revision: 1.11
Committed: Tue Aug 30 14:42:36 2011 UTC (13 years, 8 months ago) by lat
Branch: MAIN
CVS Tags: HEAD
Changes since 1.10: +0 -0 lines
State: FILE REMOVED
Error occurred while calculating annotation data.
Log Message:
Remove old obsolete RPMs and patches.

File Contents

# Content
1 ### RPM cms xcmsi-compatibility 1.0
2 # This spec is used to link the old scramdb to the new one.
3 Source: none
4 Requires: SCRAM SCRAMV1 cms-env
5
6 %prep
7 %build
8 %install
9
10 %post
11 echo "Linking old XCMSI scram database to the new one..."
12 if [ ! -f $RPM_INSTALL_PREFIX/Releases/SCRAM/scramdb/project.lookup ]
13 then
14 echo "XCMSI installation not found. Quitting without doing anything."
15 else
16 source $RPM_INSTALL_PREFIX/cmsset_default.sh
17 scramv1 db -link $RPM_INSTALL_PREFIX/Releases/SCRAM/scramdb/project.lookup
18 scramv0 db link $RPM_INSTALL_PREFIX/Releases/SCRAM/scramdb/project.lookup
19 fi
20
21 %preun
22 echo "Unlinking old XCMSI scram database from the new one..."
23 if [ ! -f $RPM_INSTALL_PREFIX/Releases/SCRAM/scramdb/project.lookup ]
24 then
25 echo "XCMSI installation not found. Quitting without doing anything."
26 exit 0
27 else
28 source $RPM_INSTALL_PREFIX/cmsset_default.sh
29 scramv1 db -unlink $RPM_INSTALL_PREFIX/Releases/SCRAM/scramdb/project.lookup
30 scramv0 db unlink $RPM_INSTALL_PREFIX/Releases/SCRAM/scramdb/project.lookup
31 fi