ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/xcmsi-compatibility.spec
Revision: 1.6
Committed: Tue Jul 4 12:53:27 2006 UTC (18 years, 10 months ago) by eulisse
Branch: MAIN
CVS Tags: for080_testfixes1, for080_testfixes, for080, for080p4, for080pre3
Changes since 1.5: +10 -10 lines
Log Message:
Source beautification...

File Contents

# Content
1 ### RPM cms xcmsi-compatibility 1.0
2 # This spec is used to link the old scramdb to the new one.
3 Source: none
4 Requires: SCRAM SCRAMV1 cms-env
5
6 %prep
7 %build
8 %install
9
10 %post
11 echo "Linking old XCMSI scram database to the new one..."
12 if [ ! -f $RPM_INSTALL_PREFIX/Releases/SCRAM/scramdb/project.lookup ]
13 then
14 echo "XCMSI installation not found. Quitting without doing anything."
15 else
16 source $RPM_INSTALL_PREFIX/cmsset_default.sh
17 scramv1 db -link $RPM_INSTALL_PREFIX/Releases/SCRAM/scramdb/project.lookup
18 fi
19
20 %preun
21 echo "Unlinking old XCMSI scram database from the new one..."
22 if [ ! -f $RPM_INSTALL_PREFIX/Releases/SCRAM/scramdb/project.lookup ]
23 then
24 echo "XCMSI installation not found. Quitting without doing anything."
25 exit 0
26 else
27 source $RPM_INSTALL_PREFIX/cmsset_default.sh
28 scramv1 db -link $RPM_INSTALL_PREFIX/Releases/SCRAM/scramdb/project.lookup
29 fi