1 |
ratnik |
1.1 |
### RPM external xdaq 3.4
|
2 |
|
|
%define xdaqv %(echo %v |tr . _)
|
3 |
|
|
# Download from cern afs area to speed up testing:
|
4 |
|
|
Source: http://cmsdoc.cern.ch/Releases/XDAQ/XDAQ_%xdaqv/coretools_G_17559_V%xdaqv.tgz
|
5 |
|
|
|
6 |
|
|
%prep
|
7 |
|
|
%setup -n TriDAS
|
8 |
|
|
echo " Install root in prep:" %{i} %{pkginstroot}
|
9 |
|
|
|
10 |
|
|
%build
|
11 |
|
|
# Xdaq does not provide makeinstall, it uses "simplify" script instead to
|
12 |
|
|
# reorganize the directory structure after the build is done.
|
13 |
|
|
# Therefore build is done in the install area.
|
14 |
|
|
|
15 |
|
|
%install
|
16 |
|
|
# Copy all code into the installation area, and build directly there:
|
17 |
|
|
cp -rp * %{i} # assuming there are no symlinks in the original source code
|
18 |
|
|
cd %{i}
|
19 |
|
|
export XDAQ_ROOT=$PWD
|
20 |
|
|
cd %{i}/daq
|
21 |
|
|
make Set=extern
|
22 |
|
|
make Set=coretools
|
23 |
|
|
# The following structure used as defined in Xdaq "simplify" script:
|
24 |
|
|
cd %{i}
|
25 |
|
|
mkdir -p %{i}/lib/linux/x86
|
26 |
|
|
mkdir -p %{i}/bin/linux/x86
|
27 |
|
|
# Catch-all
|
28 |
|
|
find . -type f ! -path "./lib/*.so" -name "*.so" -exec mv {} lib/linux/x86 \;
|
29 |
|
|
find . -type f ! -path "./bin/*.exe" -name "*.exe" -exec mv {} bin/linux/x86 \;
|
30 |
|
|
|
31 |
|
|
# Libraries from extern (not found cause they are symlinks)
|
32 |
|
|
cp -d daq/extern/*/linuxx86/lib/* lib/linux/x86
|