1 |
ratnik |
1.1 |
### RPM external xdaq 3.4
|
2 |
|
|
%define xdaqv %(echo %v |tr . _)
|
3 |
eulisse |
1.2 |
%define libext so
|
4 |
ratnik |
1.1 |
# Download from cern afs area to speed up testing:
|
5 |
eulisse |
1.2 |
Source0: http://cmsdoc.cern.ch/Releases/XDAQ/XDAQ_%xdaqv/coretools_G_17559_V%xdaqv.tgz
|
6 |
|
|
Source1: http://cmsdoc.cern.ch/Releases/XDAQ/XDAQ_%xdaqv/powerpack_G_28175_V1_3_1.tgz
|
7 |
|
|
Source2: http://cmsdoc.cern.ch/Releases/XDAQ/XDAQ_%xdaqv/worksuite_G_28176_V1_4.tgz
|
8 |
ratnik |
1.1 |
|
9 |
|
|
%prep
|
10 |
eulisse |
1.2 |
%setup -T -b 0 -n TriDAS
|
11 |
|
|
%setup -D -T -b 1 -n TriDAS
|
12 |
|
|
%setup -D -T -b 2 -n TriDAS
|
13 |
|
|
|
14 |
ratnik |
1.1 |
echo " Install root in prep:" %{i} %{pkginstroot}
|
15 |
|
|
|
16 |
|
|
%build
|
17 |
|
|
# Xdaq does not provide makeinstall, it uses "simplify" script instead to
|
18 |
|
|
# reorganize the directory structure after the build is done.
|
19 |
|
|
# Therefore build is done in the install area.
|
20 |
|
|
|
21 |
|
|
%install
|
22 |
|
|
# Copy all code into the installation area, and build directly there:
|
23 |
|
|
cp -rp * %{i} # assuming there are no symlinks in the original source code
|
24 |
|
|
cd %{i}
|
25 |
|
|
export XDAQ_ROOT=$PWD
|
26 |
|
|
cd %{i}/daq
|
27 |
eulisse |
1.2 |
make Set=extern
|
28 |
ratnik |
1.1 |
make Set=coretools
|
29 |
eulisse |
1.2 |
make Set=powerpack
|
30 |
|
|
make Set=worksuite
|
31 |
ratnik |
1.1 |
# The following structure used as defined in Xdaq "simplify" script:
|
32 |
|
|
cd %{i}
|
33 |
eulisse |
1.2 |
mkdir -p %{i}/lib
|
34 |
|
|
mkdir -p %{i}/bin
|
35 |
ratnik |
1.1 |
# Catch-all
|
36 |
eulisse |
1.2 |
find . -type f ! -path "./lib/*.%{libext}" -name "*.%{libext}" -exec mv {} %{i}/lib \;
|
37 |
|
|
find . -type f ! -path "./bin/*.exe" -name "*.exe" -exec mv {} %{i}/bin \;
|
38 |
ratnik |
1.1 |
|
39 |
|
|
# Libraries from extern (not found cause they are symlinks)
|
40 |
eulisse |
1.2 |
cp -dL daq/extern/*/linuxx86/lib/* %{i}/lib
|