ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/xdaq.spec
Revision: 1.33
Committed: Fri Jun 15 07:50:09 2007 UTC (17 years, 10 months ago) by dlange
Branch: MAIN
CVS Tags: dl070615
Changes since 1.32: +2 -2 lines
Log Message:
bump version of xdaq

File Contents

# User Rev Content
1 dlange 1.33 ### RPM external xdaq 3.9.0-CMS1
2 ratnik 1.13 Requires: zlib
3 dlange 1.33 %define xdaqv %(echo %v | cut -f1 -d- | tr . _)
4 eulisse 1.2 %define libext so
5 eulisse 1.18 %if "%cmsplatf" == "slc3_ia32_gcc323"
6     %define installDir linux/x86
7     %endif
8    
9 eulisse 1.7 # Download from cern afs area to speed up testing:
10 dlange 1.30 Source0: http://switch.dl.sourceforge.net/sourceforge/xdaq/coretools_G_V%{xdaqv}.tgz
11     Source1: http://switch.dl.sourceforge.net/sourceforge/xdaq/powerpack_G_V1_9_0.tgz
12 dlange 1.31 Source2: http://switch.dl.sourceforge.net/sourceforge/xdaq/worksuite_G_V1_8_0.tgz
13 ratnik 1.5
14 eulisse 1.7 %prep
15     %setup -T -b 0 -n TriDAS
16     %setup -D -T -b 1 -n TriDAS
17     %setup -D -T -b 2 -n TriDAS
18 eulisse 1.11 ls
19     perl -p -i -e "s|^#.*ksh(.*)|#!/usr/bin/env ksh $1|" daq/extern/SBSVME/1003/v2p3p0/sys/makefile \
20     daq/extern/SBSVME/1003/v2p3p0/sys/mkbtp
21 eulisse 1.7 echo " Install root in prep:" %{i} %{pkginstroot}
22 ratnik 1.1
23     %build
24     # Xdaq does not provide makeinstall, it uses "simplify" script instead to
25     # reorganize the directory structure after the build is done.
26     # Therefore build is done in the install area.
27    
28     %install
29     # Copy all code into the installation area, and build directly there:
30     cp -rp * %{i} # assuming there are no symlinks in the original source code
31     cd %{i}
32     export XDAQ_ROOT=$PWD
33     cd %{i}/daq
34 dlange 1.30 make CPPDEFINES=linux Set=extern_coretools
35     make CPPDEFINES=linux Set=coretools install
36     make CPPDEFINES=linux Set=extern_powerpack
37     make CPPDEFINES=linux Set=powerpack install
38    
39 ratnik 1.1 # The following structure used as defined in Xdaq "simplify" script:
40     cd %{i}
41 dlange 1.32 mv x86*/lib .
42     mv x86*/bin .
43     mv x86*/include .
44     rm -fr daq
45     rm -fr CVS
46 ratnik 1.1
47     # Libraries from extern (not found cause they are symlinks)
48 eulisse 1.3
49 eulisse 1.22 #find daq -type f ! -path "*/extern/*lib*" -name "*.a" -exec cp {} %{i}/lib \;
50 eulisse 1.11 perl -p -i -e "s|^#!.*make|#!/usr/bin/env make|" %{i}/daq/extern/slp/openslp-1.2.0/debian/rules
51 eulisse 1.12 %post
52     find $RPM_INSTALL_PREFIX/%pkgrel -type l | xargs ls -la | sed -e "s|.*[ ]\(/.*\) -> \(.*\)| \2 \1|;s|[ ]/[^ ]*/external| $RPM_INSTALL_PREFIX/%cmsplatf/external|g" | xargs -n2 ln -sf