ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/xdaq.spec
Revision: 1.35
Committed: Sat Jun 16 17:14:24 2007 UTC (17 years, 10 months ago) by dlange
Branch: MAIN
Changes since 1.34: +1 -1 lines
Log Message:
another xdaq change

File Contents

# User Rev Content
1 dlange 1.33 ### RPM external xdaq 3.9.0-CMS1
2 dlange 1.34 Requires: zlib oracle
3 dlange 1.33 %define xdaqv %(echo %v | cut -f1 -d- | tr . _)
4 eulisse 1.2 %define libext so
5 eulisse 1.18 %if "%cmsplatf" == "slc3_ia32_gcc323"
6     %define installDir linux/x86
7     %endif
8    
9 eulisse 1.7 # Download from cern afs area to speed up testing:
10 dlange 1.30 Source0: http://switch.dl.sourceforge.net/sourceforge/xdaq/coretools_G_V%{xdaqv}.tgz
11     Source1: http://switch.dl.sourceforge.net/sourceforge/xdaq/powerpack_G_V1_9_0.tgz
12 dlange 1.31 Source2: http://switch.dl.sourceforge.net/sourceforge/xdaq/worksuite_G_V1_8_0.tgz
13 dlange 1.34 Patch: xdaq_39_oracle
14 ratnik 1.5
15 eulisse 1.7 %prep
16     %setup -T -b 0 -n TriDAS
17     %setup -D -T -b 1 -n TriDAS
18     %setup -D -T -b 2 -n TriDAS
19 dlange 1.34
20     %patch0 -p2
21 eulisse 1.11 ls
22 dlange 1.34 #perl -p -i -e "s|^#.*ksh(.*)|#!/usr/bin/env ksh $1|" daq/extern/SBSVME/1003/v2p3p0/sys/makefile \
23     # daq/extern/SBSVME/1003/v2p3p0/sys/mkbtp
24 eulisse 1.7 echo " Install root in prep:" %{i} %{pkginstroot}
25 ratnik 1.1
26     %build
27     # Xdaq does not provide makeinstall, it uses "simplify" script instead to
28     # reorganize the directory structure after the build is done.
29     # Therefore build is done in the install area.
30    
31     %install
32     # Copy all code into the installation area, and build directly there:
33     cp -rp * %{i} # assuming there are no symlinks in the original source code
34     cd %{i}
35     export XDAQ_ROOT=$PWD
36     cd %{i}/daq
37 dlange 1.34 #fool xdaq for oracle and friends
38 dlange 1.35 #ln -s $ORACLE_ROOT extern/oracle/x86_slc4
39 dlange 1.34 make CPPDEFINES=linux Set=extern_coretools install
40 dlange 1.30 make CPPDEFINES=linux Set=coretools install
41 dlange 1.34 make CPPDEFINES=linux Set=extern_powerpack install
42 dlange 1.30 make CPPDEFINES=linux Set=powerpack install
43 dlange 1.34 #make CPPDEFINES=linux Set=extern_worksuite install
44     make CPPDEFINES=linux Set=worksuite install
45 dlange 1.30
46 ratnik 1.1 # The following structure used as defined in Xdaq "simplify" script:
47     cd %{i}
48 dlange 1.32 mv x86*/lib .
49     mv x86*/bin .
50     mv x86*/include .
51     rm -fr daq
52     rm -fr CVS
53 ratnik 1.1
54     # Libraries from extern (not found cause they are symlinks)
55 eulisse 1.3
56 eulisse 1.22 #find daq -type f ! -path "*/extern/*lib*" -name "*.a" -exec cp {} %{i}/lib \;
57 eulisse 1.11 perl -p -i -e "s|^#!.*make|#!/usr/bin/env make|" %{i}/daq/extern/slp/openslp-1.2.0/debian/rules
58 eulisse 1.12 %post
59     find $RPM_INSTALL_PREFIX/%pkgrel -type l | xargs ls -la | sed -e "s|.*[ ]\(/.*\) -> \(.*\)| \2 \1|;s|[ ]/[^ ]*/external| $RPM_INSTALL_PREFIX/%cmsplatf/external|g" | xargs -n2 ln -sf