ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/xdaq.spec
Revision: 1.4
Committed: Thu May 11 07:59:36 2006 UTC (18 years, 11 months ago) by eulisse
Branch: MAIN
CVS Tags: CRABSERVER_TEST_BUILD_V4, CRABSERVER_TEST_BUILD_V3, CRABSERVER_TEST_BUILD_V2, CRABSERVER_TEST_BUILD_V1, forCRABSERVER104test, forCRABSERVER103, PRODAGENT_0_10_12_V10, PRODAGENT_0_10_12_V9, PRODAGENT_0_10_12_V8, PRODAGENT_0_10_12_V7, PRODAGENT_0_10_12_V6, PRODAGENT_0_10_12_V5, PRODAGENT_0_10_12_V4, forCS102pre4, PRODAGENT_0_10_12_V3, PRODAGENT_0_10_12_V2, PRODAGENT_0_10_12, PRODAGENT_0_10_3, PRODAGENT_0_10_3_20080521, PRODAGENT_0_8_3_SL4, forPA070pre3-slc3, forPA070pre3-slc4, forPA070pre3-slc, forPA061, forPA060pre7-slc4, forPA060pre3, forDBS106, forPA050pre3, WEBTOOLS_CONFIG_1_pre2, WEBTOOLS_CONFIG_1_pre1, forPA030, forPA020, PR_0_5_4, PR_0_5_0, PR_0_4_21, PRODREQUEST_0_4_0, PR0_3_13, PR0_3_12, PR0-3-11, forPR034, forPR033, forPIL116, forPR032, forPR030, forPR020, forPA011, forPR010, forPA010, af20060928, ProdAgent_pa17, phedex_2_3_series, V00-00-09, V00-00-08, V00-00-07, V00-00-06, V00-00-05, V00-00-04
Changes since 1.3: +1 -0 lines
Log Message:
Hidden dependency on /usr/bin/make removed.

File Contents

# User Rev Content
1 ratnik 1.1 ### RPM external xdaq 3.4
2     %define xdaqv %(echo %v |tr . _)
3 eulisse 1.2 %define libext so
4 ratnik 1.1 # Download from cern afs area to speed up testing:
5 eulisse 1.2 Source0: http://cmsdoc.cern.ch/Releases/XDAQ/XDAQ_%xdaqv/coretools_G_17559_V%xdaqv.tgz
6     Source1: http://cmsdoc.cern.ch/Releases/XDAQ/XDAQ_%xdaqv/powerpack_G_28175_V1_3_1.tgz
7     Source2: http://cmsdoc.cern.ch/Releases/XDAQ/XDAQ_%xdaqv/worksuite_G_28176_V1_4.tgz
8 ratnik 1.1
9     %prep
10 eulisse 1.2 %setup -T -b 0 -n TriDAS
11     %setup -D -T -b 1 -n TriDAS
12     %setup -D -T -b 2 -n TriDAS
13    
14 ratnik 1.1 echo " Install root in prep:" %{i} %{pkginstroot}
15    
16     %build
17     # Xdaq does not provide makeinstall, it uses "simplify" script instead to
18     # reorganize the directory structure after the build is done.
19     # Therefore build is done in the install area.
20    
21     %install
22     # Copy all code into the installation area, and build directly there:
23     cp -rp * %{i} # assuming there are no symlinks in the original source code
24     cd %{i}
25     export XDAQ_ROOT=$PWD
26     cd %{i}/daq
27 eulisse 1.2 make Set=extern
28 ratnik 1.1 make Set=coretools
29 eulisse 1.2 make Set=powerpack
30     make Set=worksuite
31 ratnik 1.1 # The following structure used as defined in Xdaq "simplify" script:
32     cd %{i}
33 eulisse 1.2 mkdir -p %{i}/lib
34     mkdir -p %{i}/bin
35 ratnik 1.1 # Catch-all
36 eulisse 1.2 find . -type f ! -path "./lib/*.%{libext}" -name "*.%{libext}" -exec mv {} %{i}/lib \;
37     find . -type f ! -path "./bin/*.exe" -name "*.exe" -exec mv {} %{i}/bin \;
38 ratnik 1.1
39     # Libraries from extern (not found cause they are symlinks)
40 eulisse 1.3 cp -rdL daq/extern/*/linuxx86/lib/* %{i}/lib
41    
42     find daq -type f ! -path "*/extern/*lib*" -name "*.a" -exec cp {} %{i}/lib \;
43 eulisse 1.4 perl -p -i -e "s|^#!.*make|/usr/bin/env make|" %{i}/daq/extern/slp/openslp-1.2.0/debian/rules