ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/xdaq.spec
Revision: 1.40
Committed: Sun Jun 24 18:13:11 2007 UTC (17 years, 10 months ago) by elmer
Branch: MAIN
CVS Tags: ge20070629, pe20070626c-ports, ge20070625, pe20070626b-ports, sm20070626a-ports, pe20070626a-ports, pe20070625b-ports, pe20070625a-ports
Changes since 1.39: +2 -0 lines
Log Message:
Apply xdaq-3.9.0-nossh patch

File Contents

# User Rev Content
1 dlange 1.36 ### RPM external xdaq 3.9.0-CMS2
2 elmer 1.39 Requires: zlib mimetic xerces-c uuid
3 dlange 1.33 %define xdaqv %(echo %v | cut -f1 -d- | tr . _)
4 eulisse 1.2 %define libext so
5 eulisse 1.18 %if "%cmsplatf" == "slc3_ia32_gcc323"
6     %define installDir linux/x86
7     %endif
8    
9 eulisse 1.7 # Download from cern afs area to speed up testing:
10 dlange 1.30 Source0: http://switch.dl.sourceforge.net/sourceforge/xdaq/coretools_G_V%{xdaqv}.tgz
11     Source1: http://switch.dl.sourceforge.net/sourceforge/xdaq/powerpack_G_V1_9_0.tgz
12 dlange 1.31 Source2: http://switch.dl.sourceforge.net/sourceforge/xdaq/worksuite_G_V1_8_0.tgz
13 dlange 1.34 Patch: xdaq_39_oracle
14 elmer 1.39 Patch1: xdaq-3.9.0-uuid
15 elmer 1.40 Patch2: xdaq-3.9.0-nossh
16 ratnik 1.5
17 eulisse 1.7 %prep
18     %setup -T -b 0 -n TriDAS
19     %setup -D -T -b 1 -n TriDAS
20     %setup -D -T -b 2 -n TriDAS
21 dlange 1.34
22 dlange 1.36 #%patch0 -p2
23 elmer 1.39 %patch1 -p1
24 elmer 1.40 %patch2 -p1
25 eulisse 1.11 ls
26 dlange 1.34 #perl -p -i -e "s|^#.*ksh(.*)|#!/usr/bin/env ksh $1|" daq/extern/SBSVME/1003/v2p3p0/sys/makefile \
27     # daq/extern/SBSVME/1003/v2p3p0/sys/mkbtp
28 eulisse 1.7 echo " Install root in prep:" %{i} %{pkginstroot}
29 ratnik 1.1
30     %build
31     # Xdaq does not provide makeinstall, it uses "simplify" script instead to
32     # reorganize the directory structure after the build is done.
33     # Therefore build is done in the install area.
34    
35     %install
36     # Copy all code into the installation area, and build directly there:
37     cp -rp * %{i} # assuming there are no symlinks in the original source code
38     cd %{i}
39     export XDAQ_ROOT=$PWD
40     cd %{i}/daq
41 dlange 1.36 export MIMETIC_PREFIX=$MIMETIC_ROOT
42     export XERCES_PREFIX=$XERCES_C_ROOT
43 elmer 1.39 export UUID_LIB_PREFIX=$UUID_ROOT/lib
44 dlange 1.36
45 dlange 1.34 make CPPDEFINES=linux Set=extern_coretools install
46 dlange 1.30 make CPPDEFINES=linux Set=coretools install
47 dlange 1.34 make CPPDEFINES=linux Set=extern_powerpack install
48 dlange 1.30 make CPPDEFINES=linux Set=powerpack install
49 dlange 1.36 cd xdaq2rc
50 dlange 1.38 make CPPDEFINES=linux install
51 dlange 1.36 cd ..
52    
53 dlange 1.30
54 ratnik 1.1 # The following structure used as defined in Xdaq "simplify" script:
55     cd %{i}
56 dlange 1.32 mv x86*/lib .
57     mv x86*/bin .
58     mv x86*/include .
59 dlange 1.37 mkdir include/interface
60 dlange 1.36 mv daq/interface/evb/include/interface/evb include/interface
61     mv daq/interface/shared/include/interface/shared include/interface
62    
63 dlange 1.32 rm -fr daq
64     rm -fr CVS
65 dlange 1.37 rm -fr x86*
66 ratnik 1.1
67     # Libraries from extern (not found cause they are symlinks)
68 eulisse 1.3
69 eulisse 1.22 #find daq -type f ! -path "*/extern/*lib*" -name "*.a" -exec cp {} %{i}/lib \;
70 eulisse 1.11 perl -p -i -e "s|^#!.*make|#!/usr/bin/env make|" %{i}/daq/extern/slp/openslp-1.2.0/debian/rules
71 eulisse 1.12 %post
72     find $RPM_INSTALL_PREFIX/%pkgrel -type l | xargs ls -la | sed -e "s|.*[ ]\(/.*\) -> \(.*\)| \2 \1|;s|[ ]/[^ ]*/external| $RPM_INSTALL_PREFIX/%cmsplatf/external|g" | xargs -n2 ln -sf