ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/xdaq.spec
Revision: 1.5
Committed: Thu Jun 8 01:43:59 2006 UTC (18 years, 10 months ago) by ratnik
Branch: MAIN
CVS Tags: V00-00-10
Changes since 1.4: +12 -10 lines
Log Message:
Changes to  reduce size and re-use CMS externals: now builds only coretools, removes unneeded externals cppunit gmp tinyproxy after  building all xdaq stuff, also removes mimetic and xerces, which can be re-used via CMS configuration.  Added explicit dependency on xerces and mimetic to insure their availability.

File Contents

# User Rev Content
1 ratnik 1.1 ### RPM external xdaq 3.4
2     %define xdaqv %(echo %v |tr . _)
3 eulisse 1.2 %define libext so
4 ratnik 1.5 %define to_be_removed_externals cppunit gmp mimetic xerces tinyproxy
5    
6     Requires: xerces-c
7     Requires: mimetic
8    
9 ratnik 1.1 # Download from cern afs area to speed up testing:
10 ratnik 1.5 Source: http://cmsdoc.cern.ch/Releases/XDAQ/XDAQ_%xdaqv/coretools_G_17559_V%xdaqv.tgz
11 ratnik 1.1
12     %prep
13 ratnik 1.5 %setup -n TriDAS
14 ratnik 1.1
15     %build
16     # Xdaq does not provide makeinstall, it uses "simplify" script instead to
17     # reorganize the directory structure after the build is done.
18     # Therefore build is done in the install area.
19    
20     %install
21     # Copy all code into the installation area, and build directly there:
22     cp -rp * %{i} # assuming there are no symlinks in the original source code
23     cd %{i}
24     export XDAQ_ROOT=$PWD
25     cd %{i}/daq
26 eulisse 1.2 make Set=extern
27 ratnik 1.1 make Set=coretools
28     # The following structure used as defined in Xdaq "simplify" script:
29     cd %{i}
30 eulisse 1.2 mkdir -p %{i}/lib
31     mkdir -p %{i}/bin
32 ratnik 1.5
33     # Remove unneeded and standard externals that can be re-used from CMS distribution:
34    
35     for extern in %{to_be_removed_externals}; do echo removing external from daq: ${extern} ...; rm -rf daq/extern/${extern}; done
36    
37 ratnik 1.1 # Catch-all
38 eulisse 1.2 find . -type f ! -path "./lib/*.%{libext}" -name "*.%{libext}" -exec mv {} %{i}/lib \;
39     find . -type f ! -path "./bin/*.exe" -name "*.exe" -exec mv {} %{i}/bin \;
40 ratnik 1.1
41     # Libraries from extern (not found cause they are symlinks)
42 eulisse 1.3 cp -rdL daq/extern/*/linuxx86/lib/* %{i}/lib
43    
44     find daq -type f ! -path "*/extern/*lib*" -name "*.a" -exec cp {} %{i}/lib \;
45 eulisse 1.4 perl -p -i -e "s|^#!.*make|/usr/bin/env make|" %{i}/daq/extern/slp/openslp-1.2.0/debian/rules