Revision: | 1.9 |
Committed: | Wed Jul 5 14:52:39 2006 UTC (18 years, 9 months ago) by eulisse |
Branch: | MAIN |
Changes since 1.8: | +1 -0 lines |
Log Message: | Bumping revision to regenerate them. |
# | User | Rev | Content |
---|---|---|---|
1 | eulisse | 1.8 | ### RPM external xdaq 3.5 |
2 | eulisse | 1.7 | %define xdaqv %(echo %v |tr . _) |
3 | eulisse | 1.2 | %define libext so |
4 | eulisse | 1.7 | # Download from cern afs area to speed up testing: |
5 | #Source0: http://cmsdoc.cern.ch/Releases/XDAQ/XDAQ_%xdaqv/coretools_G_17559_V%xdaqv.tgz | ||
6 | #Source1: http://cmsdoc.cern.ch/Releases/XDAQ/XDAQ_%xdaqv/powerpack_G_28175_V1_3_1.tgz | ||
7 | #Source2: http://cmsdoc.cern.ch/Releases/XDAQ/XDAQ_%xdaqv/worksuite_G_28176_V1_4.tgz | ||
8 | Source0: http://switch.dl.sourceforge.net/sourceforge/xdaq/coretools_G_17559_V%{xdaqv}.tgz | ||
9 | Source1: http://switch.dl.sourceforge.net/sourceforge/xdaq/powerpack_G_28175_V1_4.tgz | ||
10 | Source2: http://switch.dl.sourceforge.net/sourceforge/xdaq/worksuite_G_28176_V1_5.tgz | ||
11 | ratnik | 1.5 | |
12 | eulisse | 1.7 | %prep |
13 | %setup -T -b 0 -n TriDAS | ||
14 | %setup -D -T -b 1 -n TriDAS | ||
15 | %setup -D -T -b 2 -n TriDAS | ||
16 | ratnik | 1.5 | |
17 | eulisse | 1.7 | echo " Install root in prep:" %{i} %{pkginstroot} |
18 | ratnik | 1.1 | |
19 | %build | ||
20 | # Xdaq does not provide makeinstall, it uses "simplify" script instead to | ||
21 | # reorganize the directory structure after the build is done. | ||
22 | # Therefore build is done in the install area. | ||
23 | |||
24 | %install | ||
25 | # Copy all code into the installation area, and build directly there: | ||
26 | cp -rp * %{i} # assuming there are no symlinks in the original source code | ||
27 | cd %{i} | ||
28 | export XDAQ_ROOT=$PWD | ||
29 | cd %{i}/daq | ||
30 | eulisse | 1.2 | make Set=extern |
31 | ratnik | 1.1 | make Set=coretools |
32 | eulisse | 1.7 | make Set=powerpack |
33 | make Set=worksuite | ||
34 | ratnik | 1.1 | # The following structure used as defined in Xdaq "simplify" script: |
35 | cd %{i} | ||
36 | eulisse | 1.2 | mkdir -p %{i}/lib |
37 | mkdir -p %{i}/bin | ||
38 | ratnik | 1.1 | # Catch-all |
39 | eulisse | 1.2 | find . -type f ! -path "./lib/*.%{libext}" -name "*.%{libext}" -exec mv {} %{i}/lib \; |
40 | find . -type f ! -path "./bin/*.exe" -name "*.exe" -exec mv {} %{i}/bin \; | ||
41 | ratnik | 1.1 | |
42 | # Libraries from extern (not found cause they are symlinks) | ||
43 | eulisse | 1.3 | cp -rdL daq/extern/*/linuxx86/lib/* %{i}/lib |
44 | |||
45 | find daq -type f ! -path "*/extern/*lib*" -name "*.a" -exec cp {} %{i}/lib \; | ||
46 | eulisse | 1.4 | perl -p -i -e "s|^#!.*make|/usr/bin/env make|" %{i}/daq/extern/slp/openslp-1.2.0/debian/rules |
47 | eulisse | 1.9 | # clhep.spec |