ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/xdaq.spec
Revision: 1.11
Committed: Mon Jul 17 09:45:42 2006 UTC (18 years, 9 months ago) by eulisse
Branch: MAIN
CVS Tags: for080_testfixes1, for080_testfixes, for081, for080_amd64, for080
Changes since 1.10: +4 -4 lines
Log Message:
Removes a hidden dependency on /bin/ksh

File Contents

# User Rev Content
1 eulisse 1.8 ### RPM external xdaq 3.5
2 eulisse 1.7 %define xdaqv %(echo %v |tr . _)
3 eulisse 1.2 %define libext so
4 eulisse 1.7 # Download from cern afs area to speed up testing:
5     #Source0: http://cmsdoc.cern.ch/Releases/XDAQ/XDAQ_%xdaqv/coretools_G_17559_V%xdaqv.tgz
6     #Source1: http://cmsdoc.cern.ch/Releases/XDAQ/XDAQ_%xdaqv/powerpack_G_28175_V1_3_1.tgz
7     #Source2: http://cmsdoc.cern.ch/Releases/XDAQ/XDAQ_%xdaqv/worksuite_G_28176_V1_4.tgz
8     Source0: http://switch.dl.sourceforge.net/sourceforge/xdaq/coretools_G_17559_V%{xdaqv}.tgz
9     Source1: http://switch.dl.sourceforge.net/sourceforge/xdaq/powerpack_G_28175_V1_4.tgz
10     Source2: http://switch.dl.sourceforge.net/sourceforge/xdaq/worksuite_G_28176_V1_5.tgz
11 ratnik 1.5
12 eulisse 1.7 %prep
13     %setup -T -b 0 -n TriDAS
14     %setup -D -T -b 1 -n TriDAS
15     %setup -D -T -b 2 -n TriDAS
16 eulisse 1.11 ls
17     perl -p -i -e "s|^#.*ksh(.*)|#!/usr/bin/env ksh $1|" daq/extern/SBSVME/1003/v2p3p0/sys/makefile \
18     daq/extern/SBSVME/1003/v2p3p0/sys/mkbtp
19 eulisse 1.7 echo " Install root in prep:" %{i} %{pkginstroot}
20 ratnik 1.1
21     %build
22     # Xdaq does not provide makeinstall, it uses "simplify" script instead to
23     # reorganize the directory structure after the build is done.
24     # Therefore build is done in the install area.
25    
26     %install
27     # Copy all code into the installation area, and build directly there:
28     cp -rp * %{i} # assuming there are no symlinks in the original source code
29     cd %{i}
30     export XDAQ_ROOT=$PWD
31     cd %{i}/daq
32 eulisse 1.2 make Set=extern
33 ratnik 1.1 make Set=coretools
34 eulisse 1.7 make Set=powerpack
35     make Set=worksuite
36 ratnik 1.1 # The following structure used as defined in Xdaq "simplify" script:
37     cd %{i}
38 eulisse 1.2 mkdir -p %{i}/lib
39     mkdir -p %{i}/bin
40 ratnik 1.1 # Catch-all
41 eulisse 1.2 find . -type f ! -path "./lib/*.%{libext}" -name "*.%{libext}" -exec mv {} %{i}/lib \;
42     find . -type f ! -path "./bin/*.exe" -name "*.exe" -exec mv {} %{i}/bin \;
43 ratnik 1.1
44     # Libraries from extern (not found cause they are symlinks)
45 eulisse 1.3 cp -rdL daq/extern/*/linuxx86/lib/* %{i}/lib
46    
47     find daq -type f ! -path "*/extern/*lib*" -name "*.a" -exec cp {} %{i}/lib \;
48 eulisse 1.11 perl -p -i -e "s|^#!.*make|#!/usr/bin/env make|" %{i}/daq/extern/slp/openslp-1.2.0/debian/rules