ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/xrootd.spec
Revision: 1.25
Committed: Tue Sep 22 14:39:59 2009 UTC (15 years, 7 months ago) by elmer
Branch: MAIN
CVS Tags: pe20090924a-ports, pe20090924a-for33X, pe20090923b-for33X, pe20090923b-ports, pe20090923a-ports, pe20090923a-for33X, pe20090922e-ports, pe20090922e-for33X, pe20090922d-ports, pe20090922c-ports, pe20090922c-for33X
Changes since 1.24: +14 -2 lines
Log Message:
  Remove the dependence on our own build of readline. Add a workaround
  for the fact that 32bit readline-devel system rpm is missing on SLC4
  x86_64 systems).

File Contents

# User Rev Content
1 gowdy 1.24 ### RPM external xrootd 20090727.1318
2     Source: http://project-arda-dev.web.cern.ch/project-arda-dev/xrootd/tarballs/base/%n-%{realversion}.tar.gz
3 gowdy 1.23 Patch0: xrootd-gcc44
4 elmer 1.5 Requires: openssl
5 elmer 1.1
6     %prep
7 gowdy 1.24 %setup -n %n-%{realversion}
8 gowdy 1.23 %patch0 -p1
9 elmer 1.1
10     %build
11 gowdy 1.16 ./configure.classic --disable-krb4 --with-ssl-incdir=$OPENSSL_ROOT/include --with-ssl-libdir=$OPENSSL_ROOT/lib
12 elmer 1.25 # Workaround for the lack of a 32bit readline-devel rpm for SL4
13     # Given that the 64bit readline-devel is there, the headers are there,
14     # the only thing missing is the libreadline.so symlink
15     case %cmsos in
16     slc4*ia32 )
17     mkdir tmplib
18     ln -s /usr/lib/libreadline.so.4 tmplib/libreadline.so
19     make INCKRB5=-I/usr/include/et LIBKRB5=-lkrb5 LIBREADLINE="-L$PWD/tmplib -lreadline -lcurses"
20     ;;
21     *)
22     make INCKRB5=-I/usr/include/et LIBKRB5=-lkrb5 LIBREADLINE="-lreadline -lcurses"
23     ;;
24     esac
25    
26 elmer 1.1
27     %install
28     mkdir %i/bin
29     mkdir %i/lib
30     mkdir %i/etc
31     mkdir %i/utils
32 elmer 1.2 mkdir %i/src
33 elmer 1.1 cp -r bin/arch/* %i/bin
34     cp -r lib/arch/* %i/lib
35 elmer 1.9 [ $(uname) = Darwin ] &&
36     for f in %i/lib/*.a; do
37     ranlib $f
38     done
39 elmer 1.1 cp -r utils/* %i/utils
40     cp -r etc/* %i/etc
41 elmer 1.2 cp -r src/* %i/src
42     rm -fR %i/bin/CVS %i/lib/CVS %i/utils/CVS %i/etc/CVS %i/src/CVS %i/src/*/CVS
43 elmer 1.1 # Need to fix the following in the xrootd CVS
44     perl -p -i -e 's|^#!.*perl(.*)|#!/usr/bin/env perl$1|' %i/etc/XrdOlbMonPerf
45     perl -p -i -e 's|^#!.*perl(.*)|#!/usr/bin/env perl$1|' %i/utils/mps_PreStage
46     perl -p -i -e 's|^#!.*perl(.*)|#!/usr/bin/env perl$1|' %i/utils/mps_MigrPurg
47     perl -p -i -e 's|^#!.*perl(.*)|#!/usr/bin/env perl$1|' %i/utils/fs_stat
48     perl -p -i -e 's|^#!.*perl(.*)|#!/usr/bin/env perl$1|' %i/utils/ooss_MonP.pm
49     perl -p -i -e 's|^#!.*perl(.*)|#!/usr/bin/env perl$1|' %i/utils/ooss_Lock.pm
50     perl -p -i -e 's|^#!.*perl(.*)|#!/usr/bin/env perl$1|' %i/utils/mps_prep
51     perl -p -i -e 's|^#!.*perl(.*)|#!/usr/bin/env perl$1|' %i/utils/mps_Stage
52     perl -p -i -e 's|^#!.*perl(.*)|#!/usr/bin/env perl$1|' %i/utils/ooss_name2name.pm
53     perl -p -i -e 's|^#!.*perl(.*)|#!/usr/bin/env perl$1|' %i/utils/ooss_CAlloc.pm
54     perl -p -i -e 's|^#!.*perl(.*)|#!/usr/bin/env perl$1|' %i/utils/mps_Xeq
55     perl -p -i -e 's|^#!.*perl(.*)|#!/usr/bin/env perl$1|' %i/utils/XrdOlbNotify.pm
56    
57 elmer 1.2 perl -p -i -e 's|^#!.*perl(.*)|#!/usr/bin/env perl$1|' %i/src/XrdMon/cleanup.pl
58     perl -p -i -e 's|^#!.*perl(.*)|#!/usr/bin/env perl$1|' %i/src/XrdMon/loadRTDataToMySQL.pl
59     perl -p -i -e 's|^#!.*perl(.*)|#!/usr/bin/env perl$1|' %i/src/XrdMon/xrdmonCollector.pl
60     perl -p -i -e 's|^#!.*perl(.*)|#!/usr/bin/env perl$1|' %i/src/XrdMon/prepareMySQLStats.pl
61     perl -p -i -e 's|^#!.*perl(.*)|#!/usr/bin/env perl$1|' %i/src/XrdMon/xrdmonCreateMySQL.pl
62     perl -p -i -e 's|^#!.*perl(.*)|#!/usr/bin/env perl$1|' %i/src/XrdMon/xrdmonLoadMySQL.pl
63     perl -p -i -e 's|^#!.*perl(.*)|#!/usr/bin/env perl$1|' %i/src/XrdMon/xrdmonPrepareStats.pl
64    
65 elmer 1.4 # SCRAM ToolBox toolfile
66     mkdir -p %i/etc/scram.d
67     cat << \EOF_TOOLFILE >%i/etc/scram.d/%n
68     <doc type=BuildSystem::ToolDoc version=1.0>
69     <Tool name=%n version=%v>
70     <lib name=XrdClient>
71     <lib name=XrdOuc>
72     <lib name=XrdNet>
73     <lib name=XrdSys>
74     <client>
75     <Environment name=XROOTD_BASE default="%i"></Environment>
76     <Environment name=INCLUDE default="$XROOTD_BASE/src"></Environment>
77     <Environment name=LIBDIR default="$XROOTD_BASE/lib"></Environment>
78     </client>
79     <Runtime name=PATH value="$XROOTD_BASE/bin" type=path>
80     <Runtime name=LD_LIBRARY_PATH value="$XROOTD_BASE/lib" type=path>
81     </Tool>
82     EOF_TOOLFILE
83    
84 elmer 1.1 %post
85 elmer 1.6 %{relocateConfig}etc/scram.d/%n
86 elmer 1.1