ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/xrootd.spec
Revision: 1.38
Committed: Wed Nov 3 20:21:05 2010 UTC (14 years, 5 months ago) by gowdy
Branch: MAIN
CVS Tags: for310X-101122a, for310X-101122, CMSSW_3_10_0_pre5, azFor3100p5, CMSSW_3_9_3, apFor393v0, smFor310X-101111, CMSSW_3_9_2_patch5, CMSSW_3_10_0_pre4, CMSSW_3_9_2_patch4, azFor3100pre4-Updated, smFor392p4, CMSSW_3_9_2_patch3, apFor392p3v0, CMSSW_3_9_2_patch2, apFor392p2v0, smFor310-101106, CMSSW_3_9_2_patch1, apFor392p1v0, smFor310-101104, CMSSW_3_9_2, apFor392v0, sjgFor392
Changes since 1.37: +5 -13 lines
Log Message:
add new xrootd patch for 392

File Contents

# User Rev Content
1 gowdy 1.38 ### RPM external xrootd 20090727.1318
2     Source: http://cmsrep.cern.ch//cmssw/xrootd_src/%n-%{realversion}.tar.gz
3 gowdy 1.23 Patch0: xrootd-gcc44
4 gowdy 1.38 Patch1: xrootd-readv
5 elmer 1.5 Requires: openssl
6 elmer 1.1
7     %prep
8 gowdy 1.24 %setup -n %n-%{realversion}
9 gowdy 1.23 %patch0 -p1
10 gowdy 1.38 %patch1 -p1
11 elmer 1.1
12     %build
13 elmer 1.37 ./configure.classic --disable-krb4 --with-ssl-incdir=$OPENSSL_ROOT/include --with-ssl-libdir=$OPENSSL_ROOT/lib
14 elmer 1.25 # Workaround for the lack of a 32bit readline-devel rpm for SL4
15     # Given that the 64bit readline-devel is there, the headers are there,
16     # the only thing missing is the libreadline.so symlink
17     case %cmsos in
18     slc4*ia32 )
19     mkdir tmplib
20     ln -s /usr/lib/libreadline.so.4 tmplib/libreadline.so
21     make INCKRB5=-I/usr/include/et LIBKRB5=-lkrb5 LIBREADLINE="-L$PWD/tmplib -lreadline -lcurses"
22     ;;
23     *)
24     make INCKRB5=-I/usr/include/et LIBKRB5=-lkrb5 LIBREADLINE="-lreadline -lcurses"
25     ;;
26     esac
27    
28 elmer 1.1
29     %install
30     mkdir %i/bin
31     mkdir %i/lib
32     mkdir %i/etc
33     mkdir %i/utils
34 elmer 1.2 mkdir %i/src
35 elmer 1.1 cp -r bin/arch/* %i/bin
36     cp -r lib/arch/* %i/lib
37 elmer 1.9 [ $(uname) = Darwin ] &&
38     for f in %i/lib/*.a; do
39     ranlib $f
40     done
41 elmer 1.1 cp -r utils/* %i/utils
42     cp -r etc/* %i/etc
43 elmer 1.2 cp -r src/* %i/src
44     rm -fR %i/bin/CVS %i/lib/CVS %i/utils/CVS %i/etc/CVS %i/src/CVS %i/src/*/CVS
45 elmer 1.1 # Need to fix the following in the xrootd CVS
46     perl -p -i -e 's|^#!.*perl(.*)|#!/usr/bin/env perl$1|' %i/etc/XrdOlbMonPerf
47     perl -p -i -e 's|^#!.*perl(.*)|#!/usr/bin/env perl$1|' %i/utils/mps_PreStage
48     perl -p -i -e 's|^#!.*perl(.*)|#!/usr/bin/env perl$1|' %i/utils/mps_MigrPurg
49     perl -p -i -e 's|^#!.*perl(.*)|#!/usr/bin/env perl$1|' %i/utils/fs_stat
50     perl -p -i -e 's|^#!.*perl(.*)|#!/usr/bin/env perl$1|' %i/utils/ooss_MonP.pm
51     perl -p -i -e 's|^#!.*perl(.*)|#!/usr/bin/env perl$1|' %i/utils/ooss_Lock.pm
52     perl -p -i -e 's|^#!.*perl(.*)|#!/usr/bin/env perl$1|' %i/utils/mps_prep
53     perl -p -i -e 's|^#!.*perl(.*)|#!/usr/bin/env perl$1|' %i/utils/mps_Stage
54     perl -p -i -e 's|^#!.*perl(.*)|#!/usr/bin/env perl$1|' %i/utils/ooss_name2name.pm
55     perl -p -i -e 's|^#!.*perl(.*)|#!/usr/bin/env perl$1|' %i/utils/ooss_CAlloc.pm
56     perl -p -i -e 's|^#!.*perl(.*)|#!/usr/bin/env perl$1|' %i/utils/mps_Xeq
57     perl -p -i -e 's|^#!.*perl(.*)|#!/usr/bin/env perl$1|' %i/utils/XrdOlbNotify.pm
58    
59 elmer 1.2 perl -p -i -e 's|^#!.*perl(.*)|#!/usr/bin/env perl$1|' %i/src/XrdMon/cleanup.pl
60     perl -p -i -e 's|^#!.*perl(.*)|#!/usr/bin/env perl$1|' %i/src/XrdMon/loadRTDataToMySQL.pl
61     perl -p -i -e 's|^#!.*perl(.*)|#!/usr/bin/env perl$1|' %i/src/XrdMon/xrdmonCollector.pl
62     perl -p -i -e 's|^#!.*perl(.*)|#!/usr/bin/env perl$1|' %i/src/XrdMon/prepareMySQLStats.pl
63     perl -p -i -e 's|^#!.*perl(.*)|#!/usr/bin/env perl$1|' %i/src/XrdMon/xrdmonCreateMySQL.pl
64     perl -p -i -e 's|^#!.*perl(.*)|#!/usr/bin/env perl$1|' %i/src/XrdMon/xrdmonLoadMySQL.pl
65     perl -p -i -e 's|^#!.*perl(.*)|#!/usr/bin/env perl$1|' %i/src/XrdMon/xrdmonPrepareStats.pl
66 elmer 1.37
67     # SCRAM ToolBox toolfile
68     mkdir -p %i/etc/scram.d
69     cat << \EOF_TOOLFILE >%i/etc/scram.d/%n
70     <doc type=BuildSystem::ToolDoc version=1.0>
71     <Tool name=%n version=%v>
72     <lib name=XrdClient>
73     <lib name=XrdOuc>
74     <lib name=XrdNet>
75     <lib name=XrdSys>
76     <client>
77     <Environment name=XROOTD_BASE default="%i"></Environment>
78     <Environment name=INCLUDE default="$XROOTD_BASE/src"></Environment>
79     <Environment name=LIBDIR default="$XROOTD_BASE/lib"></Environment>
80     </client>
81     <Runtime name=PATH value="$XROOTD_BASE/bin" type=path>
82     <Runtime name=LD_LIBRARY_PATH value="$XROOTD_BASE/lib" type=path>
83     </Tool>
84     EOF_TOOLFILE
85    
86     %post
87     %{relocateConfig}etc/scram.d/%n
88 gowdy 1.38