ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/zlib.spec
Revision: 1.14
Committed: Sun Oct 21 09:43:09 2007 UTC (17 years, 6 months ago) by elmer
Branch: MAIN
CVS Tags: pe20071102a-ports, forTony_001, pe20071021-170p6-zlib
Changes since 1.13: +2 -2 lines
Log Message:
Update to version 1.2.3
Apply patch zlib-1.2.3-shared-for-32-bit-on-x86_64

File Contents

# User Rev Content
1 elmer 1.14 ### RPM external zlib 1.2.3-CMS8
2 elmer 1.10 Source: http://www.gzip.org/%n/%n-%realversion.tar.bz2
3 elmer 1.14 Patch: zlib-1.2.3-shared-for-32-bit-on-x86_64
4 elmer 1.9
5     %prep
6 elmer 1.10 %setup -n %n-%realversion
7 elmer 1.9 # Apply this patch to force shared libraries to be created. The problem
8     # only appears when building 32-bit on 64-bit machines (./configure gets
9     # confused by the 'skipping /usr/lib64' message), but applying it on all
10     # linux builds should not hurt since they all should build shared libraries.
11     %ifos linux
12     %patch -p1
13     %endif
14 argiro 1.1
15     %build
16     case $(uname) in
17     Darwin )
18     LDSHARED="gcc -dynamiclib" ./configure --shared --prefix=%i
19     make LIBS='libz.dylib.$(VER)' SHAREDLIB=libz.dylib # FIXME: libz.$(VER).dylib
20     ;;
21    
22     * )
23     ./configure --shared --prefix=%i
24 eulisse 1.2 make %makeprocesses
25 argiro 1.1 ;;
26     esac
27    
28     %install
29     case $(uname) in
30     Darwin ) make install LIBS='libz.dylib.$(VER)' SHAREDLIB=libz.dylib ;;
31     * ) make install ;;
32     esac
33 eulisse 1.5 #
34 muzaffar 1.13 # SCRAM ToolBox toolfile
35     mkdir -p %i/etc/scram.d
36     cat << \EOF_TOOLFILE >%i/etc/scram.d/%n
37     <doc type=BuildSystem::ToolDoc version=1.0>
38     <Tool name=%n version=%v>
39     <lib name=z>
40     <client>
41     <Environment name=ZLIB_BASE default="%i"></Environment>
42     <Environment name=INCLUDE default="$ZLIB_BASE/include"></Environment>
43     <Environment name=LIBDIR default="$ZLIB_BASE/lib"></Environment>
44     </client>
45     </Tool>
46     EOF_TOOLFILE
47    
48     %post
49     %{relocateConfig}etc/scram.d/%n