ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/zlib.spec
Revision: 1.9
Committed: Tue May 22 00:31:14 2007 UTC (17 years, 11 months ago) by elmer
Branch: MAIN
Changes since 1.8: +11 -0 lines
Log Message:
Patch problems building shared libraries for 32-bit-on-64-bit builds.
(Patch is zlib-1.1.4-shared-for-32-bit-on-x86_64.patch)

File Contents

# User Rev Content
1 argiro 1.1 ### RPM external zlib 1.1.4
2     Source: http://www.gzip.org/%n/%n-%v.tar.bz2
3 elmer 1.9 Patch: zlib-1.1.4-shared-for-32-bit-on-x86_64
4    
5     %prep
6     %setup -n %n-%v
7     # Apply this patch to force shared libraries to be created. The problem
8     # only appears when building 32-bit on 64-bit machines (./configure gets
9     # confused by the 'skipping /usr/lib64' message), but applying it on all
10     # linux builds should not hurt since they all should build shared libraries.
11     %ifos linux
12     %patch -p1
13     %endif
14 argiro 1.1
15     %build
16     case $(uname) in
17     Darwin )
18     LDSHARED="gcc -dynamiclib" ./configure --shared --prefix=%i
19     make LIBS='libz.dylib.$(VER)' SHAREDLIB=libz.dylib # FIXME: libz.$(VER).dylib
20     ;;
21    
22     * )
23     ./configure --shared --prefix=%i
24 eulisse 1.2 make %makeprocesses
25 argiro 1.1 ;;
26     esac
27    
28     %install
29     case $(uname) in
30     Darwin ) make install LIBS='libz.dylib.$(VER)' SHAREDLIB=libz.dylib ;;
31     * ) make install ;;
32     esac
33 eulisse 1.5 #
34 eulisse 1.6 #